网络炒股按天配资-手机股票杠杆配资|股票专业配资平台-通达信战略家之时空多空能量副图指标公式(附源码破译和源码)
你的位置:网络炒股按天配资-手机股票杠杆配资|股票专业配资平台 > 手机股票杠杆配资 > 通达信战略家之时空多空能量副图指标公式(附源码破译和源码)
通达信战略家之时空多空能量副图指标公式(附源码破译和源码)
发布日期:2024-03-15 11:47    点击次数:134

编程思路破译

填充背景

V1赋值:以0.9为权重(((最高价+最低价)+(收盘价*2))/4)的动态移动平均

HY1赋值:1日前的V1的3日指数移动平均

多空趋势赋值:((收盘价-HY1)*10的2日简单移动平均)*0.1

输出操盘4:当满足条件多空趋势>=0AND多空趋势>=1日前的多空趋势时,在6.5和6.5+多空趋势位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画红色

输出减仓4:当满足条件多空趋势>=0AND多空趋势<1日前的多空趋势时,在6.5和6.5+多空趋势位置之间画柱状线,宽度为1.5,0不为0则画空心柱., 画红色

输出反弹4:当满足条件多空趋势<0AND多空趋势>=1日前的多空趋势时,在6.5和6.5+多空趋势位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色

输出寻底4:当满足条件多空趋势<0AND多空趋势<1日前的多空趋势时,在6.5和6.5+多空趋势位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色

当满足条件是否最后一个周期=1时,在如果多空趋势>=0,返回6,否则返回6.3位置书写文字,画白色

换手赋值:成交量(手)*100/当前流通股本(手)

主力赋值:换手的4日简单移动平均

大户赋值:换手的9日简单移动平均

散户赋值:换手的34日简单移动平均

均量赋值:(主力+大户+散户)/4

输出成交量:成交量(手),画白色,NODRAW

输出主力能量:(主力-均量)画洋红色,NODRAW

输出大户能量:(大户-均量)画黄色,NODRAW

输出散户能量:(散户-均量)画蓝色,NODRAW

输出操盘:当满足条件主力能量>=0AND主力能量>=1日前的主力能量时,在4.5和4.5+主力能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画黄色

输出减仓:当满足条件主力能量>=0AND主力能量<1日前的主力能量时,在4.5和4.5+主力能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画红色

输出反弹:当满足条件主力能量<0AND主力能量>=1日前的主力能量时,在4.5和4.5+主力能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色

输出寻底:当满足条件主力能量<0AND主力能量<1日前的主力能量时,在4.5和4.5+主力能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色

当满足条件是否最后一个周期=1时,在如果主力能量>=0,返回4.2,否则返回4.8位置书写文字,画洋红色

输出操盘1:当满足条件大户能量>=0AND大户能量>=1日前的大户能量时,在3和3+大户能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画白色

输出减仓1:当满足条件大户能量>=0AND大户能量<1日前的大户能量时,在3和3+大户能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画红色

输出反弹1:当满足条件大户能量<0AND大户能量>=1日前的大户能量时,在3和3+大户能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色

输出寻底1:当满足条件大户能量<0AND大户能量<1日前的大户能量时,在3和3+大户能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色

当满足条件是否最后一个周期=1时,在如果大户能量>=0,返回2.7,否则返回3.3位置书写文字,画黄色

输出操盘3:当满足条件散户能量>=0AND散户能量>=1日前的散户能量时,在0和散户能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画红色

输出减仓3:当满足条件散户能量>=0AND散户能量<1日前的散户能量时,在0和散户能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画红色

输出反弹3:当满足条件散户能量<0AND散户能量>=1日前的散户能量时,在0和散户能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色

输出寻底3:当满足条件散户能量<0AND散户能量<1日前的散户能量时,在0和散户能量位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色

当满足条件是否最后一个周期=1时,在如果散户能量>=0,返回-0.3,否则返回0.3位置书写文字,画蓝色

JZ赋值:成交量(手)/(主力能量的绝对值+大户能量的绝对值+散户能量的绝对值)

ZLCJ赋值:JZ*主力能量的绝对值

DHCJ赋值:JZ*大户能量的绝对值

SHCJ赋值:JZ*散户能量的绝对值

程序源码

DRAWGBK(CLOSE>0,RGB(0,108,108),RGB(88,0,0),0,5,0);V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);

HY1:=REF(EMA(V1,3),1);

多空趋势:=(MA((CLOSE - HY1) * 10,2))*0.1;

操盘4:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),6.5,6.5+多空趋势,1.5,0),COLORRED;

减仓4:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),6.5,6.5+多空趋势,1.5,0), COLORRED;

反弹4:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),6.5,6.5+多空趋势,1.5,0),COLORGREEN;

寻底4:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),6.5,6.5+多空趋势,1.5,0),COLORGREEN;

DRAWTEXT(ISLASTBAR=1,IF(多空趋势>=0,6,6.3),' 多空'),COLORWHITE;

换手:=V*100/CAPITAL;

主力:=MA(换手,4);

大户:=MA(换手,9);

散户:=MA(换手,34);

均量:=(主力+大户+散户)/4;

成交量:V,COLORWHITE,NODRAW;

主力能量:(主力-均量)COLORMAGENTA,NODRAW;

大户能量:(大户-均量)COLORYELLOW,NODRAW;

散户能量:(散户-均量)COLORBLUE,NODRAW;

操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1.5,0),COLORYELLOW;

减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1.5,0),COLORRED;

反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1.5,0),COLORGREEN;

寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1.5,0),COLORGREEN;

DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,4.2,4.8),' 机构'),COLORMAGENTA;

操盘1:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),3,3+大户能量,1.5,0),COLORWHITE;

减仓1:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),3,3+大户能量,1.5,0),COLORRED;

反弹1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),3,3+大户能量,1.5,0),COLORGREEN;

寻底1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),3,3+大户能量,1.5,0),COLORGREEN;

DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,2.7,3.3),' 大户'),COLORYELLOW;

操盘3:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),0,散户能量,1.5,0),COLORRED;

减仓3:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),0,散户能量,1.5,0),COLORRED;

反弹3:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),0,散户能量,1.5,0),COLORGREEN;

寻底3:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),0,散户能量,1.5,0),COLORGREEN;

DRAWTEXT(ISLASTBAR=1,IF(散户能量>=0,-0.3,0.3),' 散户'),COLORBLUE;

JZ:=V/(ABS(主力能量)+ABS(大户能量)+ABS(散户能量));

ZLCJ:=JZ*ABS(主力能量);

DHCJ:=JZ*ABS(大户能量);

SHCJ:=JZ*ABS(散户能量);

该公式包含未来函数:CAPITAL

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。