网络炒股按天配资-手机股票杠杆配资|股票专业配资平台-通达信奇迹龙年抄底佳品副图指标公式(附源码破译和源码)
你的位置:网络炒股按天配资-手机股票杠杆配资|股票专业配资平台 > 手机股票杠杆配资 > 通达信奇迹龙年抄底佳品副图指标公式(附源码破译和源码)
通达信奇迹龙年抄底佳品副图指标公式(附源码破译和源码)
发布日期:2024-03-15 10:59    点击次数:191

编程思路破译

VAR1赋值:最高价的8日简单移动平均*(1+3/100)

VAR2赋值:最低价的8日简单移动平均*(1-3/100)

VAR3赋值:最低价的30日简单移动平均*(1-15/100)

VAR4赋值:1日前的收盘价<1日前的VAR2 AND 1日前的收盘价<1日前的VAR3 AND 开盘价<1日前的收盘价 AND 收盘价>VAR2 AND 收盘价>VAR3 AND 收盘价/1日前的收盘价>1.05 AND VAR1/收盘价>1.05

VAR5赋值:上次VAR4距今天数<=10

VAR6赋值:最低价<=VAR2*1.005 AND 开盘价>1日前的收盘价*0.9 AND 上次VAR4距今天数>=1 AND 1日前的最高价<1日前的VAR1 AND 2日前的最高价<2日前的VAR1 AND 3日前的最高价<3日前的VAR1 AND 4日前的最高价<4日前的VAR1 AND 5日前的最高价<5日前的VAR1 AND 6日前的最高价<6日前的VAR1 AND 7日前的最高价<7日前的VAR1 AND 8日前的最高价<8日前的VAR1 AND 9日前的最高价<9日前的VAR1 AND 10日前的最高价<10日前的VAR1

VAR7赋值:VAR5 AND VAR6

VAR8赋值: VAR3上穿VAR2 AND 3日内最低价的最低值<3日前的120日内最低价的最低值 AND 1日前的收盘价/开盘价<1.05 AND 收盘价的有效数据周期数>500 AND VAR1/收盘价>1.08

VAR9赋值:1日前的收盘价/开盘价>1.093 AND 最高价=最低价 AND 平盘

VAR10赋值:统计10日中满足VAR9的天数<1

输出奇迹龙年:VAR7 OR VAR8 AND VAR10 LINESTICK 画淡红色

程序源码

VAR1:=MA(H,8)*(1+3/100);

VAR2:=MA(L,8)*(1-3/100);

VAR3:=MA(L,30)*(1-15/100);

VAR4:=REF(C,1)<REF(VAR2,1) AND REF(C,1)<REF(VAR3,1) AND O<REF(C,1) AND C>VAR2 AND C>VAR3 AND C/REF(C,1)>1.05 AND VAR1/C>1.05;

VAR5:=BARSLAST(VAR4)<=10;

VAR6:=L<=VAR2*1.005 AND O>REF(C,1)*0.9 AND BARSLAST(VAR4)>=1 AND REF(H,1)<REF(VAR1,1) AND REF(H,2)<REF(VAR1,2) AND REF(H,3)<REF(VAR1,3) AND REF(H,4)<REF(VAR1,4) AND REF(H,5)<REF(VAR1,5) AND REF(H,6)<REF(VAR1,6) AND REF(H,7)<REF(VAR1,7) AND REF(H,8)<REF(VAR1,8) AND REF(H,9)<REF(VAR1,9) AND REF(H,10)<REF(VAR1,10);

VAR7:=VAR5 AND VAR6;

VAR8:= CROSS(VAR3,VAR2) AND LLV(L,3)<REF(LLV(L,120),3) AND REF(C,1)/O<1.05 AND BARSCOUNT(C)>500 AND VAR1/C>1.08;

VAR9:=REF(C,1)/O>1.093 AND H=L AND O=C;

VAR10:=COUNT(VAR9,10)<1;

奇迹龙年:VAR7 OR VAR8 AND VAR10 LINESTICK COLORLIRED;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。