网络炒股按天配资-手机股票杠杆配资|股票专业配资平台-通达信战略家之时空旋涡战法副图指标公式(附源码破译和源码)
你的位置:网络炒股按天配资-手机股票杠杆配资|股票专业配资平台 > 网络炒股按天配资 > 通达信战略家之时空旋涡战法副图指标公式(附源码破译和源码)
通达信战略家之时空旋涡战法副图指标公式(附源码破译和源码)
发布日期:2024-03-15 12:15    点击次数:201

编程思路破译

填充背景

XA_1赋值:3日前的收盘价/4日前的收盘价>1.09

XA_2赋值:收盘价/1日前的收盘价>=1.031 AND 开盘价/3日前的开盘价位于1.1和0.91之间 AND 最低价<3日前的收盘价 AND 1日前的收盘价/2日前的收盘价<0.965 AND 1日前的收盘价<1日前的开盘价 AND 取反 AND 取反

XA_3赋值:XA_1 AND XA_2

XA_4赋值:4日前的收盘价/5日前的收盘价>1.09 AND 4日前的收盘价=4日前的最高价

XA_5赋值:收盘价/1日前的收盘价>=1.031 AND 开盘价/4日前的开盘价位于1.1和0.91之间 AND 最低价<4日前的收盘价 AND 1日前的收盘价/2日前的收盘价<0.96 AND 1日前的收盘价<1日前的开盘价

XA_6赋值:取反

XA_7赋值:XA_4 AND XA_5 AND XA_6

XA_8赋值:5日前的收盘价/6日前的收盘价>1.09 AND 5日前的收盘价=5日前的最高价

XA_9赋值:收盘价/1日前的收盘价>=1.031 AND 开盘价/5日前的开盘价位于1.1和0.91之间 AND 最低价<5日前的收盘价 AND 1日前的收盘价/2日前的收盘价<0.96 AND 1日前的收盘价<1日前的开盘价 AND 取反 AND 取反 AND 取反

XA_10赋值:XA_8 AND XA_9

XA_11赋值:3日前的收盘价/4日前的收盘价>1.09

XA_12赋值:收盘价/1日前的收盘价>=1.031 AND 开盘价/3日前的开盘价位于1.1和0.91之间 AND 最低价<3日前的收盘价 AND 最近4日一直存在收盘价的5日简单移动平均>收盘价的10日简单移动平均 AND 1日前的开盘价/1日前的收盘价的5日简单移动平均位于1.01和0.99之间

XA_13赋值:XA_11 AND XA_12

XA_14赋值:XA_3 OR XA_7 OR XA_10 OR XA_13

XA_15赋值:4日前的收盘价/5日前的收盘价>1.09 AND 4日前的收盘价=4日前的最高价

XA_16赋值:收盘价/1日前的收盘价>=1.031 AND 1日前的收盘价<4日前的收盘价 AND 1日前的收盘价/2日前的收盘价位于1.015和0.985之间 AND 开盘价<4日前的收盘价 AND 开盘价<收盘价的5日简单移动平均 AND 最近2日一直存在1日前的收盘价的5日简单移动平均>1日前的收盘价的10日简单移动平均

XA_17赋值:1日前的最高价>1日前的收盘价

XA_18赋值:取反

XA_19赋值:XA_15 AND XA_16 AND XA_17 AND XA_18

XA_20赋值:3日前的收盘价/4日前的收盘价>1.09 AND 3日前的收盘价=3日前的最高价

XA_21赋值:收盘价/1日前的收盘价>=1.031 AND 1日前的收盘价<3日前的收盘价 AND (1日前的收盘价/2日前的收盘价<0.96 AND 1日前的收盘价<1日前的开盘价 AND 1日前的开盘价/1日前的收盘价<1.01) AND 开盘价<3日前的收盘价 AND 开盘价<收盘价的5日简单移动平均 AND 最近2日一直存在1日前的收盘价的5日简单移动平均>1日前的收盘价的10日简单移动平均

XA_22赋值:1日前的最高价>1日前的收盘价

XA_23赋值:XA_20 AND XA_21 AND XA_22

XA_24赋值:3日前的收盘价/4日前的收盘价>1.09 AND 3日前的收盘价=3日前的最高价

XA_25赋值:收盘价/1日前的收盘价>=1.031 AND 1日前的收盘价<3日前的收盘价 AND (1日前的收盘价<1日前的开盘价 AND 1日前的开盘价/1日前的收盘价<1.01) AND 开盘价<3日前的收盘价 AND 开盘价<收盘价的5日简单移动平均 AND 最近3日一直存在1日前的收盘价的5日简单移动平均>1日前的收盘价的10日简单移动平均

XA_26赋值:1日前的最高价>1日前的收盘价

XA_27赋值:XA_24 AND XA_25 AND XA_26

XA_28赋值:取反

XA_29赋值:XA_19 OR XA_23 OR XA_27 AND XA_28

XA_30赋值:如果模糊匹配品种名称,返回0,否则返回1 AND 如果模糊匹配品种名称,返回0,否则返回1

XA_31赋值:如果模糊匹配品种代码,返回0,否则返回1

时空旋涡赋值:XA_14 OR XA_29 AND XA_30 AND XA_31,画红色,线宽为2

当满足条件时空旋涡时,在0和2位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色

当满足条件时空旋涡时,在9和11位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色

当满足条件时空旋涡时,在8位置书写文字,画黄色

当满足条件时空旋涡时,在1位置画9号图标

当满足条件时空旋涡时,在2位置画2号图标

当满足条件时空旋涡时,在3位置画1号图标

当满足条件时空旋涡时,在4位置画1号图标

当满足条件时空旋涡时,在5位置画1号图标

当满足条件时空旋涡时,在6位置画1号图标

当满足条件时空旋涡时,在7位置画28号图标

当满足条件时空旋涡时,在8位置画1号图标

当满足条件时空旋涡时,在9位置画1号图标

当满足条件时空旋涡时,在10位置画9号图标

当满足条件时空旋涡时,在11位置画1号图标

程序源码

DRAWGBK(CLOSE>0,RGB(0,108,108),RGB(88,0,0),0,5,0);XA_1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09;

XA_2:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,3),1.1,0.91) AND LOW<REF(CLOSE,3) AND REF(CLOSE,1)/REF(CLOSE,2)<0.965 AND REF(CLOSE,1)<REF(OPEN,1) AND NOT(REF(HIGH,2)/REF(CLOSE,3)>1.09 AND REF(HIGH,2)/MAX(REF(CLOSE,2),REF(OPEN,2))>1.07) AND NOT(REF(CLOSE,2)<REF(OPEN,2) AND REF(OPEN,2)/REF(CLOSE,3)>1.09);

XA_3:=XA_1 AND XA_2;

XA_4:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(HIGH,4);

XA_5:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,4),1.1,0.91) AND LOW<REF(CLOSE,4) AND REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)<REF(OPEN,1);

XA_6:=NOT(REF(OPEN,3)/REF(CLOSE,3)>1.07 AND REF(OPEN,3)>REF(CLOSE,4) AND REF(CLOSE,3)<REF(LOW,4));

XA_7:=XA_4 AND XA_5 AND XA_6;

XA_8:=REF(CLOSE,5)/REF(CLOSE,6)>1.09 AND REF(CLOSE,5)=REF(HIGH,5);

XA_9:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,5),1.1,0.91) AND LOW<REF(CLOSE,5) AND REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)<REF(OPEN,1) AND NOT(REF(HIGH,4)/REF(CLOSE,5)>1.05 AND REF(HIGH,4)/MAX(REF(CLOSE,4),REF(OPEN,4))>1.07) AND NOT(REF(LOW,4)/REF(CLOSE,5)>1.02 AND REF(CLOSE,4)<REF(OPEN,4) AND MA(CLOSE,10)/OPEN>1.03 AND REF(OPEN,1)<REF(MA(CLOSE,10),1)) AND NOT(REF(OPEN,3)/REF(CLOSE,3)>1.07 AND REF(OPEN,3)>REF(CLOSE,4) AND REF(CLOSE,3)<REF(LOW,4) AND REF(CLOSE,4)/REF(CLOSE,5)>1.09);

XA_10:=XA_8 AND XA_9;

XA_11:=REF(CLOSE,3)/REF(CLOSE,4)>1.09;

XA_12:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,3),1.1,0.91) AND LOW<REF(CLOSE,3) AND EVERY(MA(CLOSE,5)>MA(CLOSE,10),4) AND BETWEEN(REF(OPEN,1)/REF(MA(CLOSE,5),1),1.01,0.99);

XA_13:=XA_11 AND XA_12;

XA_14:=XA_3 OR XA_7 OR XA_10 OR XA_13;

XA_15:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(HIGH,4);

XA_16:=CLOSE/REF(CLOSE,1)>=1.031 AND REF(CLOSE,1)<REF(CLOSE,4) AND BETWEEN(REF(CLOSE,1)/REF(CLOSE,2),1.015,0.985) AND OPEN<REF(CLOSE,4) AND OPEN<MA(CLOSE,5) AND EVERY(REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1),2);

XA_17:=REF(HIGH,1)>REF(CLOSE,1);

XA_18:=NOT(REF(CLOSE,1)>REF(OPEN,1) AND REF(CLOSE,1)/REF(OPEN,1)>1.03);

XA_19:=XA_15 AND XA_16 AND XA_17 AND XA_18;

XA_20:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(HIGH,3);

XA_21:=CLOSE/REF(CLOSE,1)>=1.031 AND REF(CLOSE,1)<REF(CLOSE,3) AND (REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)<REF(OPEN,1) AND REF(OPEN,1)/REF(CLOSE,1)<1.01) AND OPEN<REF(CLOSE,3) AND OPEN<MA(CLOSE,5) AND EVERY(REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1),2);

XA_22:=REF(HIGH,1)>REF(CLOSE,1);

XA_23:=XA_20 AND XA_21 AND XA_22;

XA_24:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(HIGH,3);

XA_25:=CLOSE/REF(CLOSE,1)>=1.031 AND REF(CLOSE,1)<REF(CLOSE,3) AND (REF(CLOSE,1)<REF(OPEN,1) AND REF(OPEN,1)/REF(CLOSE,1)<1.01) AND OPEN<REF(CLOSE,3) AND OPEN<MA(CLOSE,5) AND EVERY(REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1),3);

XA_26:=REF(HIGH,1)>REF(CLOSE,1);

XA_27:=XA_24 AND XA_25 AND XA_26{2};

XA_28:=NOT(REF(CLOSE,4)/REF(CLOSE,5)>1.095 AND REF(CLOSE,3)/REF(CLOSE,4)<0.92 AND REF(OPEN,3)>REF(CLOSE,4) AND REF(CLOSE,3)<REF(OPEN,4));

XA_29:=XA_19 OR XA_23 OR XA_27 AND XA_28;

XA_30:=IF(NAMELIKE(2),0,1) AND IF(NAMELIKE(3),0,1);

XA_31:=IF(CODELIKE(1),0,1);

时空旋涡:=XA_14 OR XA_29 AND XA_30 AND XA_31,COLORRED,LINETHICK2;

STICKLINE(时空旋涡,0,2,3,1),COLORYELLOW;

STICKLINE(时空旋涡,9,11,3,1),COLORYELLOW;

DRAWTEXT(时空旋涡,8,' 时空旋涡'),COLORYELLOW;

DRAWICON(时空旋涡,1,9);

DRAWICON(时空旋涡,2,2);

DRAWICON(时空旋涡,3,1);

DRAWICON(时空旋涡,4,1);

DRAWICON(时空旋涡,5,1);

DRAWICON(时空旋涡,6,1);

DRAWICON(时空旋涡,7,28);

DRAWICON(时空旋涡,8,1);

DRAWICON(时空旋涡,9,1);

DRAWICON(时空旋涡,10,9);

DRAWICON(时空旋涡,11,1);

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。