网络炒股按天配资-手机股票杠杆配资|股票专业配资平台-通达信捕捞季节副图指标公式(附源码破译和源码及使用说明)
你的位置:网络炒股按天配资-手机股票杠杆配资|股票专业配资平台 > 网络炒股按天配资 > 通达信捕捞季节副图指标公式(附源码破译和源码及使用说明)
通达信捕捞季节副图指标公式(附源码破译和源码及使用说明)
发布日期:2024-03-15 12:08    点击次数:106

编程思路破译

WY1001赋值:(2*收盘价+最高价+最低价)/3

WY1002赋值:WY1001的3日指数移动平均

WY1003赋值:WY1002的3日指数移动平均

WY1004赋值:WY1003的3日指数移动平均

输出XYS0:(WY1004-1日前的WY1004)/1日前的WY1004*100

当满足条件XYS0>=0时,在XYS0和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色

当满足条件XYS0<0时,在XYS0和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色

PJGJ赋值:成交额(元)/成交量(手)/100

SSRYDJX赋值:PJGJ的13日简单移动平均

SSRCJL赋值:成交量(手)的13日指数移动平均

SSRCJE赋值:成交额(元)的13日指数移动平均

SSRCBJX赋值:SSRCJE/SSRCJL/100

CYS13赋值:(收盘价-SSRCBJX)/SSRCBJX*100

XYSHSL赋值:成交量(手)/当前流通股本(手)*100的13日指数移动平均

输出ZZX:0,画白色

当满足条件XYSHSL>6.1ANDCYS13>5时,在2和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色

当满足条件XYSHSL>3.8ANDCYS13>5时,在1.5和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色

当满足条件XYSHSL>2.1ANDCYS13>5时,在1和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画青色

当满足条件XYSHSL>1.8ANDCYS13>5时,在0.5和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色

输出XYS1:XYS0的1日简单移动平均

输出XYS2:XYS0的2日简单移动平均

当满足条件XYS1上穿XYS2时,在XYS2位置画1号图标

程序源码

WY1001:=(2*CLOSE+HIGH+LOW)/3;

WY1002:=EMA(WY1001,3);

WY1003:=EMA(WY1002,3);

WY1004:=EMA(WY1003,3);

XYS0:(WY1004-REF(WY1004,1))/REF(WY1004,1)*100;

STICKLINE(XYS0>=0,XYS0,0,2,0),COLORRED;

STICKLINE(XYS0<0,XYS0,0,2,0),COLORGREEN;

PJGJ:=AMOUNT/VOL/100;

SSRYDJX:=MA(PJGJ,13);

SSRCJL:=EMA(VOL,13);

SSRCJE:=EMA(AMOUNT,13);

SSRCBJX:=SSRCJE/SSRCJL/100;

CYS13:=(CLOSE-SSRCBJX)/SSRCBJX*100;

XYSHSL:=EMA(VOL/CAPITAL*100,13);

ZZX:0,COLORWHITE;

STICKLINE(XYSHSL>6.1 AND CYS13>5 ,2 ,0 ,2,0 ),COLORGREEN;

STICKLINE(XYSHSL>3.8 AND CYS13>5 ,1.5 ,0 ,2 ,0 ),COLORYELLOW;

STICKLINE(XYSHSL>2.1 AND CYS13>5 ,1 ,0 ,2,0 ),COLORCYAN;

STICKLINE(XYSHSL>1.8 AND CYS13>5 ,0.5 ,0 ,2,0 ),COLORBLUE;

XYS1:MA(XYS0,1);

XYS2:MA(XYS0,2);

DRAWICON(CROSS(XYS1,XYS2),XYS2,1)

该公式包含未来函数:CAPITAL

使用说明

紫色上穿緑色线买入,紫色下穿緑色线卖出。

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。