网络炒股按天配资-手机股票杠杆配资|股票专业配资平台-通达信反弹出击抄底副图指标公式(附源码破译和源码)
你的位置:网络炒股按天配资-手机股票杠杆配资|股票专业配资平台 > 股票专业配资平台 > 通达信反弹出击抄底副图指标公式(附源码破译和源码)
通达信反弹出击抄底副图指标公式(附源码破译和源码)
发布日期:2024-03-15 12:11    点击次数:190

编程思路破译

X_1赋值:9

X_2赋值:收盘价<=1日前的X_1日内收盘价的最低值 AND 收盘价<=开盘价

X_3赋值:1日前的X_2 AND 收阳线ANDSE 收盘价<=1日前的收盘价

X_4赋值:X_2 OR X_3 AND 上市的天数>20

X_5赋值:(收盘价-1日前的收盘价)/1日前的收盘价>=0.04 OR (收盘价-开盘价)/开盘价>=0.04 AND (成交量(手)<=成交量(手)的60日简单移动平均 OR 成交量(手)/1日前的成交量(手)<=1.2 OR 成交量(手)<5日内成交量(手)的最高值) AND 最高价>最低价

X_6赋值:(开盘价-收盘价)/开盘价>=0.04 OR (1日前的收盘价/收盘价>=1.04 AND 收阴线) AND (成交量(手)/成交量(手)的60日简单移动平均<=2/3 OR 成交量(手)/1日前的成交量(手)<=1.15 OR 成交量(手)<5日内成交量(手)的最高值)

X_7赋值:收阴线

X_8赋值:2日前的成交量(手)>1日前的成交量(手) AND 1日前的成交量(手)>成交量(手) AND 统计3日中满足X_7的天数>=2

X_9赋值:成交量(手)<1日前的20日内成交量(手)的最低值 AND 最高价>最低价

X_10赋值:2日前的成交量(手)>1日前的成交量(手) AND 1日前的成交量(手)>成交量(手)

X_11赋值:成交量(手)/1日前的成交量(手)<0.67

X_12赋值:如果日期=1160107,返回1日前的成交量(手),否则返回成交量(手)

X_13赋值:X_12<1日前的100日内X_12的最低值 AND 最高价>最低价

X_14赋值:成交量(手)/成交量(手)的60日简单移动平均<=1/3

X_15赋值:X_4 AND X_6 AND 统计3日中满足X_10ORX_11ORX_13的天数

X_16赋值:1日前的X_15 AND 收阳线ANDSE 成交量(手)>1日前的成交量(手) AND (收盘价>1日前的(收盘价+开盘价)/2 OR 收盘价/开盘价>1.008)

X_17赋值:1日前的X_15 OR (2日前的X_15 AND 1日前的收盘价<1日前的开盘价) AND 收阳线ANDSE 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的开盘价

X_18赋值:1日前的X_15 AND X_5 OR (2日前的X_15 AND 1日前的成交量(手)<成交量(手)) AND X_5

X_19赋值:1日前的收盘价<1日前的开盘价 AND 收盘价>1日前的开盘价 AND 开盘价<1日前的收盘价

X_20赋值:1日前的X_15 OR 2日前的X_15 AND X_19 AND 收盘价/开盘价>1.02

X_21赋值:100*(收盘价和开盘价的较小值-最低价)/最低价>3.5

X_22赋值:1日前的X_15 OR 2日前的X_15 AND X_21 AND 收阳线

X_23赋值:1日前的X_15 AND 1日前的X_21 OR (2日前的X_15 AND (2日前的X_21 OR 1日前的X_21)) AND 收盘价/开盘价>1.02

X_24赋值:X_22 OR X_23

X_25赋值:1日前的X_15 AND 收盘价/开盘价>1.01 AND 成交量(手)<1日前的成交量(手)

X_26赋值:X_16 OR X_17 OR X_18 OR X_20 OR X_24 OR X_25

输出反弹出击:X_26的2日过滤,画黄色,线宽为2

程序源码

X_1:=9;

X_2:=CLOSE<=REF(LLV(CLOSE,X_1),1) AND CLOSE<=OPEN;

X_3:=REF(X_2,1) AND CLOSE>OPEN AND CLOSE<=REF(CLOSE,1);

X_4:=X_2 OR X_3 AND FINANCE(42)>20;{这个 FINANCE 是上市天数大于20天的意思,并非未来函数}

X_5:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04 OR (CLOSE-OPEN)/OPEN>=0.04 AND (VOL<=MA(VOL,60) OR VOL/REF(VOL,1)<=1.2 OR VOL<HHV(VOL,5)) AND HIGH>LOW;

X_6:=(OPEN-CLOSE)/OPEN>=0.04 OR (REF(CLOSE,1)/CLOSE>=1.04 AND CLOSE<OPEN) AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5));

X_7:=CLOSE<OPEN;

X_8:=REF(VOL,2)>REF(VOL,1) AND REF(VOL,1)>VOL AND COUNT(X_7,3)>=2;

X_9:=VOL<REF(LLV(VOL,20),1) AND HIGH>LOW;

X_10:=REF(VOL,2)>REF(VOL,1) AND REF(VOL,1)>VOL;

X_11:=VOL/REF(VOL,1)<0.67;

X_12:=IF(DATE=1160107,REF(VOL,1),VOL);

X_13:=X_12<REF(LLV(X_12,100),1) AND HIGH>LOW;

X_14:=VOL/MA(VOL,60)<=1/3;

X_15:=X_4 AND X_6 AND COUNT(X_10 OR X_11 OR X_13,3);

X_16:=REF(X_15,1) AND CLOSE>OPEN AND VOL>REF(VOL,1) AND (CLOSE>REF((CLOSE+OPEN)/2,1) OR CLOSE/OPEN>1.008);

X_17:=REF(X_15,1) OR (REF(X_15,2) AND REF(CLOSE,1)<REF(OPEN,1)) AND CLOSE>OPEN AND VOL>REF(VOL,1) AND CLOSE>REF(OPEN,1);

X_18:=REF(X_15,1) AND X_5 OR (REF(X_15,2) AND REF(VOL,1)<VOL) AND X_5;

X_19:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);

X_20:=REF(X_15,1) OR REF(X_15,2) AND X_19 AND CLOSE/OPEN>1.02;

X_21:=100*(MIN(CLOSE,OPEN)-LOW)/LOW>3.5;

X_22:=REF(X_15,1) OR REF(X_15,2) AND X_21 AND CLOSE>OPEN;

X_23:=REF(X_15,1) AND REF(X_21,1) OR (REF(X_15,2) AND (REF(X_21,2) OR REF(X_21,1))) AND CLOSE/OPEN>1.02;

X_24:=X_22 OR X_23;

X_25:=REF(X_15,1) AND CLOSE/OPEN>1.01 AND VOL<REF(VOL,1);

X_26:=X_16 OR X_17 OR X_18 OR X_20 OR X_24 OR X_25;

反弹出击:FILTER(X_26,2),COLORYELLOW,LINETHICK2;

该公式包含未来函数:FINANCE

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。