网络炒股按天配资-手机股票杠杆配资|股票专业配资平台-同花顺三龙聚首副图副图指标公式(附源码破译和源码)
你的位置:网络炒股按天配资-手机股票杠杆配资|股票专业配资平台 > 股票专业配资平台 > 同花顺三龙聚首副图副图指标公式(附源码破译和源码)
同花顺三龙聚首副图副图指标公式(附源码破译和源码)
发布日期:2024-03-15 12:13    点击次数:139

编程思路破译

TJ赋值:0日后的&收盘价>0

RUNO赋值:0

输出上趋势:如果TJ+RUNO,返回最低价的20日简单移动平均*1.2,否则返回NULL,画洋红色,CROSSDOT

输出次上趋势:如果TJ+RUNO,返回最低价的20日简单移动平均*1.1,否则返回NULL,画黄色

输出次下趋势:如果TJ+RUNO,返回最高价的20日简单移动平均*0.9,否则返回NULL,画白色

输出下趋势:如果TJ+RUNO,返回最高价的20日简单移动平均*0.8,否则返回NULL,画绿色,CROSSDOT

ZD赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100

HDZF赋值:(20日内最高价的最高值-收盘价)/(20日内最高价的最高值-20日内最低价的最低值)

趋势强度赋值:如果收盘价>次上趋势,返回如果收盘价>上趋势,返回4,否则返回3,否则返回如果收盘价>次下趋势ANDC<次上趋势,返回2,否则返回如果收盘价<下趋势,返回0,否则返回1

当满足条件趋势强度=0AND(TJ+RUNO)时,在最高价和最低价位置之间画柱状线,宽度为8,1不为0则画空心柱.,画蓝色

当满足条件趋势强度=1AND(TJ+RUNO)时,在最高价和最低价位置之间画柱状线,宽度为8,1不为0则画空心柱.,画绿色

当满足条件趋势强度=2AND(TJ+RUNO)时,在最高价和最低价位置之间画柱状线,宽度为8,1不为0则画空心柱.,画深灰色

当满足条件趋势强度=3AND(TJ+RUNO)时,在最高价和最低价位置之间画柱状线,宽度为8,1不为0则画空心柱.,画黄色

当满足条件趋势强度=4AND(TJ+RUNO)时,在最高价和最低价位置之间画柱状线,宽度为8,1不为0则画空心柱.,画洋红色

当满足条件趋势强度=0AND(TJ+RUNO)时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,画蓝色

当满足条件趋势强度=1AND(TJ+RUNO)时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,画绿色

当满足条件趋势强度=2AND(TJ+RUNO)时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,画深灰色

当满足条件趋势强度=3AND(TJ+RUNO)时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,画黄色

当满足条件趋势强度=4AND(TJ+RUNO)时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,画洋红色

程序源码

TJ:=REFX(&CLOSE,0)>0;

RUNO:=0;

上趋势:IF(TJ+RUNO,MA(LOW,20)*1.2,NULL),COLORMAGENTA,CROSSDOT;

次上趋势:IF(TJ+RUNO,MA(LOW,20)*1.1,NULL),COLORYELLOW;

次下趋势:IF(TJ+RUNO,MA(HIGH,20)*0.9,NULL),COLORWHITE;

下趋势:IF(TJ+RUNO,MA(HIGH,20)*0.8,NULL),COLORGREEN,CROSSDOT;

ZD:=(C-REF(C,1))/REF(C,1)*100;

HDZF:=(HHV(H,20)-C)/(HHV(H,20)-LLV(L,20));

趋势强度:=IF(C>次上趋势,IF(C>上趋势,4,3),IF(C>次下趋势 AND C<次上趋势,2,IF(C<下趋势,0,1)));

STICKLINE(趋势强度=0 AND (TJ+RUNO),H,L,8,1),COLORBLUE;

STICKLINE(趋势强度=1 AND (TJ+RUNO),H,L,8,1),COLORGREEN;

STICKLINE(趋势强度=2 AND (TJ+RUNO),H,L,8,1),COLORGRAY;

STICKLINE(趋势强度=3 AND (TJ+RUNO),H,L,8,1),COLORYELLOW;

STICKLINE(趋势强度=4 AND (TJ+RUNO),H,L,8,1),COLORMAGENTA;

STICKLINE(趋势强度=0 AND (TJ+RUNO),C,O,7,0),COLORBLUE;

STICKLINE(趋势强度=1 AND (TJ+RUNO),C,O,7,0),COLORGREEN;

STICKLINE(趋势强度=2 AND (TJ+RUNO),C,O,7,0),COLORGRAY;

STICKLINE(趋势强度=3 AND (TJ+RUNO),C,O,7,0),COLORYELLOW;

STICKLINE(趋势强度=4 AND (TJ+RUNO),C,O,7,0),COLORMAGENTA;

该公式包含未来函数:REFX

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。