网络炒股按天配资-手机股票杠杆配资|股票专业配资平台-通达信区间历史资料主图指标公式(附源码破译和源码)
你的位置:网络炒股按天配资-手机股票杠杆配资|股票专业配资平台 > 股票专业配资平台 > 通达信区间历史资料主图指标公式(附源码破译和源码)
通达信区间历史资料主图指标公式(附源码破译和源码)
发布日期:2024-03-15 11:08    点击次数:122

编程思路破译

超赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100

指赋值:(收盘价-收盘价的12日简单移动平均)/收盘价的12日简单移动平均*100

GGFFF1赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100

BIAS赋值:(超+2*指+3*GGFFF1)/6

AA赋值:BIAS的3日简单移动平均

输出   布林极限:当满足条件AA<-12ANDAA>=-18时,在2和0位置之间画柱状线,宽度为6,0不为0则画空心柱.,画红色

输出   CC:如果AA<-18,返回3,否则返回0,COLORFF35FF,线宽为1

   当满足条件AA<-18时,在3和0位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFF35FF

GFFCC1赋值:以成交量(手)/成交量(手)的4日简单移动平均/4为权重收盘价的动态移动平均

GFFCC2赋值:以成交量(手)/成交量(手)的31日简单移动平均/31为权重收盘价的动态移动平均

GFFCC3赋值:(收盘价-GFFCC1)/GFFCC1*100<-10

GFFCC4赋值:(GFFCC1-GFFCC2)/GFFCC2*100<-16

GFFCC5赋值:(收盘价-收盘价的50日简单移动平均)/收盘价的50日简单移动平均*100<-23

GFFCC6赋值:收盘价-1日前的收盘价和0的较大值的3日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的3日[1日权重]移动平均*100>16

GFFCC7赋值:100*(27日内最高价的最高值-收盘价)/(27日内最高价的最高值-27日内最低价的最低值)

GFFCC8赋值:大盘的收盘价

GFFCC9赋值:GFFCC8的6日简单移动平均

GFFCCA赋值:GFFCC8的24日简单移动平均

GFFCCB赋值:GFFCC8的32日简单移动平均

GFFCCC赋值:GFFCCB>GFFCC9*1.11ANDGFFCCA>GFFCC9*1.095

SSS赋值:(GFFCC3ANDGFFCC4AND(开盘价-1日前的收盘价)/1日前的收盘价>-0.07ORGFFCC5ANDGFFCC6ANDCROSS(GFFCC7,79)ORGFFCCC)*100

输出   DD:SSS>0,画白色,线宽为1

N赋值:8

趋势赋值:收盘价N%的之字转向

   画带状线

↑转向赋值:收盘价N%之字转向的前1个波谷位置

↓转向赋值:收盘价N%之字转向的前1个波峰位置

L低赋值:如果↑转向=0,返回收盘价,否则返回如果↓转向<↑转向,返回收盘价N%之字转向的前1个波谷值,否则返回1日前的收盘价N%之字转向的前1个波谷值

H高赋值:如果↓转向=0,返回收盘价,否则返回如果↑转向<↓转向,返回收盘价N%之字转向的前1个波峰值,否则返回1日前的收盘价N%之字转向的前1个波峰值

低高运行赋值:上次↓转向=0距今天数日前的上次趋势<1日前的趋势距今天数

高低运行赋值:上次↑转向=0距今天数日前的上次趋势>1日前的趋势距今天数

输出   现区间运行天数:如果↑转向<↓转向,返回上次趋势<1日前的趋势距今天数,否则返回上次趋势>1日前的趋势距今天数,COLORFF00FF,NODRAW

前1区间运行赋值:如果↑转向<↓转向,返回高低运行,否则返回低高运行

高低距赋值:上次↓转向<↑转向AND↓转向>0AND趋势>L低距今天数日前的H高-L低

低高距赋值:上次↑转向<↓转向AND↑转向>0AND趋势<H高距今天数日前的H高-L低

前1区间距赋值:如果↑转向>↓转向,返回高低距,否则返回低高距

区间涨%赋值:如果↑转向<↓转向,返回(收盘价/L低-1)*100,否则返回↓转向日前的(收盘价/L低-1)*100

区间跌%赋值:如果↓转向<↑转向,返回(收盘价/H高-1)*100,否则返回↑转向日前的(收盘价/H高-1)*100

输出   现区间涨跌:如果ISLASTBARAND趋势<1日前的趋势,返回区间跌%,否则返回区间涨%,COLORFFFF00,NODRAW

输出   上:如果趋势>1日前的趋势,返回趋势,否则返回无效数,画红色,线宽为2

输出   下:如果趋势<1日前的趋势,返回趋势,否则返回无效数,画绿色,线宽为2

   当满足条件↑转向=0时,在最低价*0.95和H高位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00

   当满足条件↓转向=0时,在最高价*1.03和L低位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF00FF

   当满足条件↑转向位于0和7之间时,在L低和L低位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLOR00FFFF

   当满足条件↓转向位于0和7之间时,在H高和H高位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLOR00FF00

   当满足条件↑转向<↓转向时,在L低和L低位置之间画柱状线,宽度为1,1不为0则画空心柱.,COLOR00FFFF

   当满足条件↓转向<↑转向时,在H高和H高位置之间画柱状线,宽度为1,1不为0则画空心柱.,COLOR00FF00

   当满足条件↑转向=0时,在最低价*0.98位置书写数字,COLORFFFFFF

   当满足条件↑转向=0时,在H高位置书写数字,COLORFF0000

   当满足条件↑转向=0时,在(H高+L低)/2位置书写数字,COLORFFFF00

   当满足条件↓转向=0时,在最高价*1.02位置书写数字,COLORFFFFFF

   当满足条件↓转向=0时,在(H高+L低)/2位置书写数字,COLORFFFF00

   当满足条件↓转向=0时,在L低位置书写数字,COLORFF0000

   当满足条件ISLASTBARAND趋势<1日前的趋势时,在(H高+趋势)/2位置书写数字,COLORFFFF00

   当满足条件ISLASTBARAND趋势>1日前的趋势时,在(趋势+L低)/2位置书写数字,COLORFFFF00

   当满足条件是否最后一个周期时,在横轴0纵轴0.01位置书写文字,COLORFFFFFF

   当满足条件是否最后一个周期时,在横轴0纵轴0.05位置书写文字,COLORFF0000

   当满足条件是否最后一个周期时,在横轴0纵轴0.09位置书写文字,COLORFFFF00

   DRAWGBKLAST(日期>900101,STRIP(自定色,自定色,1))

输出   现价:如果开盘价=0,返回收盘价,否则返回现价,COLOR0077FF,POINTDOT

X赋值:上次DISPSTATUS=1距今天数+1

输出输出   DRAWTEXTABS(500,10,'★['+STKLABEL+']'+品种名称+':【可视:'+X+'天,】'),COLOR00FFFF,线宽为7,LAYER0

输出   MA5:收盘价的5日简单移动平均,COLOR00FFFF,PRECIS2

输出   MA10:收盘价的10日简单移动平均,PRECIS2

输出   MA20:收盘价的20日简单移动平均,PRECIS2

输出   MA30:收盘价的30日简单移动平均,PRECIS2

输出   MA60:收盘价的60日简单移动平均,PRECIS2

输出   MA120:收盘价的120日简单移动平均,PRECIS2,线宽为0

   [新]条件颜色线,线宽为2

输出   多空均线:(收盘价的3日加权移动平均+收盘价的6日加权移动平均+收盘价的12日加权移动平均+收盘价的24日加权移动平均)/4的13日指数移动平均,COLOR00FF00,线宽为0

   [新]条件颜色线,线宽为2

   FILLRGN(MA5,BBI,(MA5>1日前的MA5)-1,自定色,1,自定色),线宽为2,LAYER7

      当满足条件收阳线时,在最高价和最低价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000FF

   当满足条件开盘价>=收盘价时,在最高价和最低价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00FF00

   当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR006600

   当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLOR009900

   当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR00BB00

   当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00DD00

   当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FF00

   当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR000566

   当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLOR000499

   当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR0003BB

   当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0002DD

   当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0001FF

   DRAWRECTABS(5,2,99,396,自定色),COLOR44FF00,线宽为2,LAYER0

   DRAWRECTABS(100,2,420,396,自定色),COLOR0044FF,线宽为2,LAYER0

   DRAWTEXTABS(20,15,'今日【C】'+NUMTOSTRN((收盘价),2)+'元。'+NUMTOSTRN((最高价),2)+'元。'),COLOR44FF00,线宽为2,LAYER0

   DRAWTEXTABS(20,45,'5日【C】'+NUMTOSTRN((5日内收盘价的最高值),2)+'元。'+NUMTOSTRN((5日内最高价的最高值),2)+'元。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,75,'10日【C】'+NUMTOSTRN((10日内收盘价的最高值),2)+'元。'+NUMTOSTRN((10日内最高价的最高值),2)+'元。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,105,'20日【C】'+NUMTOSTRN((20日内收盘价的最高值),2)+'元。'+NUMTOSTRN((20日内最高价的最高值),2)+'元。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,135,'30日【C】'+NUMTOSTRN((30日内收盘价的最高值),2)+'元。'+NUMTOSTRN((30日内最高价的最高值),2)+'元。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,165,'60日【C】'+NUMTOSTRN((60日内收盘价的最高值),2)+'元。'+NUMTOSTRN((60日内最高价的最高值),2)+'元。'),COLOR4477FF,线宽为2,LAYER0

   DRAWTEXTABS(10,195,'90日【C】'+NUMTOSTRN((90日内收盘价的最高值),2)+'元。'+NUMTOSTRN((90日内最高价的最高值),2)+'元。'),COLOR00FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,225,'120日【C】'+NUMTOSTRN((120日内收盘价的最高值),2)+'元'+NUMTOSTRN((120日内最高价的最高值),2)+'元。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,255,'240日【C】'+NUMTOSTRN((240日内收盘价的最高值),2)+'元。'+NUMTOSTRN((240日内最高价的最高值),2)+'元。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,285,'480日【C】'+NUMTOSTRN((480日内收盘价的最高值),2)+'元。'+NUMTOSTRN((480日内最高价的最高值),2)+'元。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,315,'2400日【C】'+NUMTOSTRN((2400日内收盘价的最高值),2)+'元。'+NUMTOSTRN((2400日内最高价的最高值),2)+'元。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(10,345,'最高【C】'+NUMTOSTRN((0日内收盘价的最高值),2)+'元。'+NUMTOSTRN((0日内最高价的最高值),2)+'元。'),COLOR00FF00,线宽为2,LAYER0

   DRAWTEXTABS(10,375,''+X+'日【C】'+NUMTOSTRN((X日内收盘价的最高值),2)+'元。'+NUMTOSTRN((X日内最高价的最高值),2)+'元。'),COLOR0000FF,线宽为2,LAYER0

   DRAWRECTABS(100,4,100+(收盘价)/收盘价*100,14,自定色),LAYER0

   DRAWRECTABS(100,34,100+(5日内收盘价的最高值)/收盘价*100,44,自定色),LAYER0

   DRAWRECTABS(100,64,100+(10日内收盘价的最高值)/收盘价*100,74,自定色),LAYER0

   DRAWRECTABS(100,94,100+(20日内收盘价的最高值)/收盘价*100,104,自定色),LAYER0

   DRAWRECTABS(100,124,100+(30日内收盘价的最高值)/收盘价*100,134,自定色),LAYER0

   DRAWRECTABS(100,154,100+(60日内收盘价的最高值)/收盘价*100,164,自定色),LAYER0

   DRAWRECTABS(100,184,100+(90日内收盘价的最高值)/收盘价*100,194,自定色),LAYER0

   DRAWRECTABS(100,214,100+(120日内收盘价的最高值)/收盘价*100,224,自定色),LAYER0

   DRAWRECTABS(100,244,100+(240日内收盘价的最高值)/收盘价*100,254,自定色),LAYER0

   DRAWRECTABS(100,274,100+(480日内收盘价的最高值)/收盘价*100,284,自定色),LAYER0

   DRAWRECTABS(100,304,100+(2400日内收盘价的最高值)/收盘价*100,314,自定色),LAYER0

   DRAWRECTABS(100,334,100+(0日内收盘价的最高值)/收盘价*100,344,自定色),LAYER0

   DRAWRECTABS(100,364,100+(X日内收盘价的最高值)/收盘价*100,374,自定色),LAYER0

   DRAWTEXTABS(280,15,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100,2)+'%。'),COLOR00FF00,线宽为3,LAYER0

   DRAWTEXTABS(280,45,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的5日累和,0)+'%。'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的5日累和/5,2)+'%。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,75,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的10日累和,0)+'%。'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的10日累和/10,2)+'%。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,105,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的20日累和,0)+'%。'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的20日累和/20,2)+'%。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,135,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的30日累和,0)+'%。'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的30日累和/30,2)+'%。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,165,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的60日累和,0)+'%。'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的60日累和/60,2)+'%。'),COLOR44FF00,线宽为2,LAYER0

   DRAWTEXTABS(280,195,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的90日累和,0)+'%。'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的90日累和/90,2)+'%。'),COLOR00FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,225,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的120日累和,0)+'%'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的120日累和/120,2)+'%。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,255,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的240日累和,0)+'%'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的240日累和/240,2)+'%。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,285,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的480日累和,0)+'%'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的480日累和/480,2)+'%。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,315,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的2400日累和,0)+'%'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的2400日累和/2400,2)+'%。'),COLOR44FFFF,线宽为2,LAYER0

   DRAWTEXTABS(280,345,''+NUMTOSTRN((0日内成交量(手)/当前流通股本(手)*100的最高值),2)+'%'),COLOR00FF00,线宽为3,LAYER0

   DRAWTEXTABS(280,375,''+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的X日累和,0)+'%。'+NUMTOSTRN(成交量(手)/当前流通股本(手)*100的X日累和/X,2)+'%。'),COLOR0044FF,线宽为2,LAYER0

程序源码

超:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

   指:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

   GGFFF1:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

   BIAS:=(超+2*指+3*GGFFF1)/6;

   AA:=MA(BIAS,3);

   BB:STICKLINE(AA<-12ANDAA>=-18,2,0,6,0),COLORRED;

   CC:IF(AA<-18,3,0),COLORFF35FF,LINETHICK1;

   STICKLINE(AA<-18,3,0,6,0),COLORFF35FF;

   GFFCC1:=DMA(CLOSE,VOL/MA(VOL,4)/4);

   GFFCC2:=DMA(CLOSE,VOL/MA(VOL,31)/31);

   GFFCC3:=(CLOSE-GFFCC1)/GFFCC1*100<-10;

   GFFCC4:=(GFFCC1-GFFCC2)/GFFCC2*100<-16;

   GFFCC5:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;

   GFFCC6:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;

   GFFCC7:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));

   GFFCC8:=INDEXC;

   GFFCC9:=MA(GFFCC8,6);

   GFFCCA:=MA(GFFCC8,24);

   GFFCCB:=MA(GFFCC8,32);

   GFFCCC:=GFFCCB>GFFCC9*1.11ANDGFFCCA>GFFCC9*1.095;

   SSS:=(GFFCC3ANDGFFCC4AND(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07ORGFFCC5ANDGFFCC6ANDCROSS(GFFCC7,79)ORGFFCCC)*100;

   DD:SSS>0,COLORWHITE,LINETHICK1;

   N:=8;

   趋势:=ZIG(3,N);

   DRAWBAND(趋势,RGB(255,255,255),趋势,RGB(255,255,255));

   ↑转向:=TROUGHBARS(3,N,1);

   ↓转向:=PEAKBARS(3,N,1);

   L低:=IF(↑转向=0,C,IF(↓转向<↑转向,TROUGH(3,N,1),REF(TROUGH(3,N,1),1)));

   H高:=IF(↓转向=0,C,IF(↑转向<↓转向,PEAK(3,N,1),REF(PEAK(3,N,1),1)));

   低高运行:=REF(BARSLAST(趋势<REF(趋势,1)),BARSLAST(↓转向=0));

   高低运行:=REF(BARSLAST(趋势>REF(趋势,1)),BARSLAST(↑转向=0));

   现区间运行天数:IF(↑转向<↓转向,BARSLAST(趋势<REF(趋势,1)),BARSLAST(趋势>REF(趋势,1))),COLORFF00FF,NODRAW;

   前1区间运行:=IF(↑转向<↓转向,高低运行,低高运行);

   高低距:=REF(H高-L低,BARSLAST(↓转向<↑转向AND↓转向>0AND趋势>L低));

   低高距:=REF(H高-L低,BARSLAST(↑转向<↓转向AND↑转向>0AND趋势<H高));

   前1区间距:=IF(↑转向>↓转向,高低距,低高距);

   区间涨%:=IF(↑转向<↓转向,(C/L低-1)*100,REF((C/L低-1)*100,↓转向));

   区间跌%:=IF(↓转向<↑转向,(C/H高-1)*100,REF((C/H高-1)*100,↑转向));

   现区间涨跌:IF(ISLASTBARAND趋势<REF(趋势,1),区间跌%,区间涨%),COLORFFFF00,NODRAW;

   上:IF(趋势>REF(趋势,1),趋势,DRAWNULL),COLORRED,LINETHICK2;

   下:IF(趋势<REF(趋势,1),趋势,DRAWNULL),COLORGREEN,LINETHICK2;

   STICKLINE(↑转向=0,L*0.95,H高,0,0),COLOR00FF00;

   STICKLINE(↓转向=0,H*1.03,L低,0,0),COLORFF00FF;

   STICKLINE(BETWEEN(↑转向,0,7),L低,L低,3,1),COLOR00FFFF;

   STICKLINE(BETWEEN(↓转向,0,7),H高,H高,3,1),COLOR00FF00;

   STICKLINE(↑转向<↓转向,L低,L低,1,1),COLOR00FFFF;

   STICKLINE(↓转向<↑转向,H高,H高,1,1),COLOR00FF00;

   DRAWNUMBER(↑转向=0,L*0.98,前1区间运行),COLORFFFFFF;

   DRAWNUMBER(↑转向=0,H高,ABS(H高-L低)),COLORFF0000;

   DRAWNUMBER(↑转向=0,(H高+L低)/2,区间跌%),COLORFFFF00;

   DRAWNUMBER(↓转向=0,H*1.02,前1区间运行),COLORFFFFFF;

   DRAWNUMBER(↓转向=0,(H高+L低)/2,区间涨%),COLORFFFF00;

   DRAWNUMBER(↓转向=0,L低,ABS(H高-L低)),COLORFF0000;

   DRAWNUMBER(ISLASTBARAND趋势<REF(趋势,1),(H高+趋势)/2,区间跌%),COLORFFFF00;

   DRAWNUMBER(ISLASTBARAND趋势>REF(趋势,1),(趋势+L低)/2,区间涨%),COLORFFFF00;

   DRAWTEXT_FIX(ISLASTBAR,0,0.01,0,'■前区间运行天数。'),COLORFFFFFF;

   DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,'■前区间运行价差。'),COLORFF0000;

   DRAWTEXT_FIX(ISLASTBAR,0,0.09,0,'■前区间涨跌幅度。'),COLORFFFF00;

   DRAWGBKLAST(DATE>900101,STRIP(RGB(5,5,5),RGB(5,4,100),1));

   现价:IF(DYNAINFO(4)=0,C,DYNAINFO(7)),COLOR0077FF,POINTDOT;

   X:=BARSLAST(DISPSTATUS=1)+1;

   DRAWTEXTABS(500,10,'★['+STKLABEL+']'+STKNAME+':【可视:'+X+'天,】'),COLOR00FFFF,LINETHICK7,LAYER0;

   MA5:MA(C,5),COLOR00FFFF,PRECIS2;

   MA10:MA(C,10),PRECIS2;

   MA20:MA(C,20),PRECIS2;

   MA30:MA(C,30),PRECIS2;

   MA60:MA(C,60),PRECIS2;

   MA120:MA(C,120),PRECIS2,LINETHICK0;

   PARTLINE(MA5,MA5>REF(MA5,1),RGB(255,0,0),MA5<REF(MA5,1),RGB(0,255,0)),LINETHICK2;

   BBI:EMA((WMA(CLOSE,3)+WMA(CLOSE,6)+WMA(CLOSE,12)+WMA(CLOSE,24))/4,13),COLOR00FF00,LINETHICK0;;

   PARTLINE(BBI,BBI>REF(BBI,1),RGB(255,0,0),BBI<REF(BBI,1),RGB(0,255,0)),LINETHICK2;

   FILLRGN(MA5,BBI,(MA5>REF(MA5,1))-1,RGB(60,0,60),1,RGB(0,0,255)),LINETHICK2,LAYER7;

   {K线}

   STICKLINE(CLOSE>OPEN,HIGH,LOW,0.5,0),COLOR0000FF;

   STICKLINE(OPEN>=CLOSE,HIGH,LOW,0.5,0),COLOR00FF00;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8,0),COLOR006600;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7,0),COLOR009900;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5,0),COLOR00BB00;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLOR00DD00;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),COLOR00FF00;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),COLOR000566;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0),COLOR000499;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0),COLOR0003BB;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR0002DD;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),COLOR0001FF;

   DRAWRECTABS(5,2,99,396,RGB(0,60,0)),COLOR44FF00,LINETHICK2,LAYER0;;

   DRAWRECTABS(100,2,420,396,RGB(40,0,50)),COLOR0044FF,LINETHICK2,LAYER0;;

   DRAWTEXTABS(20,15,'今日【C】'+NUMTOSTRN((C),2)+'元。'+NUMTOSTRN((H),2)+'元。'),COLOR44FF00,LINETHICK2,LAYER0;

   DRAWTEXTABS(20,45,'5日【C】'+NUMTOSTRN((HHV(C,5)),2)+'元。'+NUMTOSTRN((HHV(H,5)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,75,'10日【C】'+NUMTOSTRN((HHV(C,10)),2)+'元。'+NUMTOSTRN((HHV(H,10)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,105,'20日【C】'+NUMTOSTRN((HHV(C,20)),2)+'元。'+NUMTOSTRN((HHV(H,20)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,135,'30日【C】'+NUMTOSTRN((HHV(C,30)),2)+'元。'+NUMTOSTRN((HHV(H,30)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,165,'60日【C】'+NUMTOSTRN((HHV(C,60)),2)+'元。'+NUMTOSTRN((HHV(H,60)),2)+'元。'),COLOR4477FF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,195,'90日【C】'+NUMTOSTRN((HHV(C,90)),2)+'元。'+NUMTOSTRN((HHV(H,90)),2)+'元。'),COLOR00FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,225,'120日【C】'+NUMTOSTRN((HHV(C,120)),2)+'元'+NUMTOSTRN((HHV(H,120)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,255,'240日【C】'+NUMTOSTRN((HHV(C,240)),2)+'元。'+NUMTOSTRN((HHV(H,240)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,285,'480日【C】'+NUMTOSTRN((HHV(C,480)),2)+'元。'+NUMTOSTRN((HHV(H,480)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,315,'2400日【C】'+NUMTOSTRN((HHV(C,2400)),2)+'元。'+NUMTOSTRN((HHV(H,2400)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,345,'最高【C】'+NUMTOSTRN((HHV(C,0)),2)+'元。'+NUMTOSTRN((HHV(H,0)),2)+'元。'),COLOR00FF00,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,375,''+X+'日【C】'+NUMTOSTRN((HHV(C,X)),2)+'元。'+NUMTOSTRN((HHV(H,X)),2)+'元。'),COLOR0000FF,LINETHICK2,LAYER0;

   DRAWRECTABS(100,4,100+(C)/C*100,14,RGB(255,0,0)),LAYER0;

   DRAWRECTABS(100,34,100+(HHV(C,5))/C*100,44,RGB(0,255,0)),LAYER0;

   DRAWRECTABS(100,64,100+(HHV(C,10))/C*100,74,RGB(0,155,100)),LAYER0;

   DRAWRECTABS(100,94,100+(HHV(C,20))/C*100,104,RGB(250,55,0)),LAYER0;

   DRAWRECTABS(100,124,100+(HHV(C,30))/C*100,134,RGB(250,155,0)),LAYER0;

   DRAWRECTABS(100,154,100+(HHV(C,60))/C*100,164,RGB(0,205,200)),LAYER0;

   DRAWRECTABS(100,184,100+(HHV(C,90))/C*100,194,RGB(255,0,100)),LAYER0;

   DRAWRECTABS(100,214,100+(HHV(C,120))/C*100,224,RGB(0,155,100)),LAYER0;

   DRAWRECTABS(100,244,100+(HHV(C,240))/C*100,254,RGB(50,255,20)),LAYER0;

   DRAWRECTABS(100,274,100+(HHV(C,480))/C*100,284,RGB(250,55,0)),LAYER0;

   DRAWRECTABS(100,304,100+(HHV(C,2400))/C*100,314,RGB(0,205,20)),LAYER0;

   DRAWRECTABS(100,334,100+(HHV(C,0))/C*100,344,RGB(255,255,0)),LAYER0;

   DRAWRECTABS(100,364,100+(HHV(C,X))/C*100,374,RGB(255,0,0)),LAYER0;

   DRAWTEXTABS(280,15,''+NUMTOSTRN(VOL/CAPITAL*100,2)+'%。'),COLOR00FF00,LINETHICK3,LAYER0;

   DRAWTEXTABS(280,45,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,5),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,5)/5,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,75,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,10),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,10)/10,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,105,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,20),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,20)/20,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,135,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,30),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,30)/30,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,165,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,60),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,60)/60,2)+'%。'),COLOR44FF00,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,195,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,90),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,90)/90,2)+'%。'),COLOR00FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,225,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,120),0)+'%'+NUMTOSTRN(SUM(VOL/CAPITAL*100,120)/120,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,255,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,240),0)+'%'+NUMTOSTRN(SUM(VOL/CAPITAL*100,240)/240,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,285,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,480),0)+'%'+NUMTOSTRN(SUM(VOL/CAPITAL*100,480)/480,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,315,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,2400),0)+'%'+NUMTOSTRN(SUM(VOL/CAPITAL*100,2400)/2400,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,345,''+NUMTOSTRN((HHV(VOL/CAPITAL*100,0)),2)+'%'),COLOR00FF00,LINETHICK3,LAYER0;

   DRAWTEXTABS(280,375,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,X),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,X)/X,2)+'%。'),COLOR0044FF,LINETHICK2,LAYER0;

该公式包含未来函数:ZIG该公式包含未来函数:PEAK该公式包含未来函数:PEAKBARS该公式包含未来函数:TROUGH该公式包含未来函数:TROUGHBARS未发现:FLATZIG...未发现:FLATZIGA...未发现:PEAKA...未发现:PEAKBARSA...未发现:TROUGHA...未发现:ZIGA...未发现:FFT...未发现:BACKSET...未发现:WINNER...未发现:LWINNER...未发现:PWINNER...未发现:COST...该公式包含未来函数:CAPITAL该公式包含未来函数:DYNAINFO

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。